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WARRANTY

Tektronix warrants that the media on which this software product is furnished and the encoding of the programs on the media
will be free from defects in materials and workmanship for a period of three (3) months from the date of shipment. If a
medium or encoding proves defective during the warranty period, Tektronix will provide a replacement in exchange for the
defective medium. Except as to the media on which this software product is furnished, this software product is provided “as
is” without warranty of any kind, either express or implied. Tektronix does not warrant that the functions contained in this
software product will meet Customer’s requirements or that the operation of the programs will be uninterrupted or error-free.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the
warranty period. If Tektronix is unable to provide a replacement that is free from defects in materials and workmanship
within a reasonable time thereafter, Customer may terminate the license for this software product and return this software
product and any associated materials for credit or refund.

THIS WARRANTY IS GIVEN BY TEKTRONIX IN LIEU OF ANY OTHER WARRANTIES, EXPRESS OR
IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX’ RESPONSIBILITY TO
REPLACE DEFECTIVE MEDIA OR REFUND CUSTOMER’S PAYMENT IS THE SOLE AND EXCLUSIVE
REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY. TEKTRONIX AND ITS
VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL
DAMAGES IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS ADVANCE NOTICE OF
THE POSSIBILITY OF SUCH DAMAGES.






SOFTWARE LICENSE AGREEMENT

THE ENCLOSED OR ACCOMPANYING PROGRAM IS FURNISHED SUBJECT TO THE TERMS AND
CONDITIONS OF THIS AGREEMENT. USE OF THE PROGRAM IN ANY MANNER, DOWNLOADING AND
UNPACKING THE PROGRAM FROM ITS COMPRESSED STATE OR INSTALLING THE PROGRAM FROM A
CD WILL BE CONSIDERED ACCEPTANCE OF THE AGREEMENT TERMS. IF THESE TERMS ARE NOT
ACCEPTABLE, THE UNUSED PROGRAM AND ANY ACCOMPANYING DOCUMENTATION SHOULD BE
RETURNED PROMPTLY TO TEKTRONIX FOR A REFUND OF ANY LICENSE FEE PAID FOR THE
PROGRAM.

DEFINITIONS

“Program” means the software product (executable program and/or data) accompanying this Agreement or included within
the equipment with which this Agreement is packed.

“Customer” means the person or organization in whose name the Program was ordered.

LICENSE
Customer may:

a. Use the Program on a single machine;

b. Copy the Program for archival or backup purposes, provided that no more than one (1) such copy is permitted to exist at
any one time, and provided each copy of the Program made by Customer includes a reproduction of any copyright notice or
restrictive rights legend appearing in or on the Program as received from Tektronix.

Customer may not:
a. Use the Program on more than one machine;

b. Transfer the Program to any person or organization outside of Customer or the corporation of which Customer is a part
without the prior written consent of Tektronix;

c. Export or re-export, directly or indirectly, the Program, any associated documentation, or the direct product thereof, to any
country to which such export or re-export is restricted by law or regulation of the United States or any foreign government
having jurisdiction without obtaining any required U.S. and other government license, authorization or approval;

d. Reverse engineer, disassemble, decompile or otherwise reduce the Program to a human-perceivable form;
e. Modify, network, rent, lease, loan or distribute the Program or create derivative works based on the Program; or
f. Copy the documentation accompanying the Program.

Title to the Program and all copies thereof, but not the media on which the Program or copies may reside, shall be and remain
with Tektronix or others from whom Tektronix has obtained a respective licensing right.

Customer shall pay when due all property taxes that may now or hereafter be imposed, levied or assessed with respect to the
possession or use of the Program or this license and shall file all reports required in connection with such taxes.

THE PROGRAM MAY NOT BE USED, COPIED, MODIFIED, MERGED, OR TRANSFERRED TO ANOTHER
EXCEPT AS EXPRESSLY PERMITTED BY THESE TERMS AND CONDITIONS.



UPON TRANSFER OF ANY COPY, MODIFICATION, OR MERGED PORTION OF THE PROGRAM WITHOUT
THE PRIOR WRITTEN CONSENT OF TEKTRONIX, THE LICENSE GRANTED HEREIN IS
AUTOMATICALLY TERMINATED.

TERM

The license granted herein is effective upon acceptance by Customer, and shall remain in effect until terminated as provided
herein. The license may be terminated by Customer at any time upon written notice to Tektronix. The license may be
terminated by Tektronix or any third party from whom Tektronix may have obtained a respective licensing right if Customer
fails to comply with any term or condition and such failure is not remedied within thirty (30) days after notice thereof from
Tektronix or such third party. Upon termination by either party, Customer shall return to Tektronix, or destroy, the Program
and all associated documentation, together with all copies in any form.

LIMITED WARRANTY

Tektronix warrants that the media on which the Program is furnished and the encoding of the Program on the media will be
free from defects in materials and workmanship for a period of three (3) months from the date of shipment. If any such
medium or encoding proves defective during the warranty period, Tektronix will provide a replacement in exchange for the
defective medium. Except as to the media on which the Program is furnished, the Program is provided As is without warranty
of any kind, either express or implied. Tektronix does not warrant that the functions contained in the Program will meet
Customer’s requirements or that the operation of the Program will be uninterrupted or error-free.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the
warranty period. If Tektronix is unable to provide a replacement that is free from defects in materials and workmanship
within a reasonable time thereafter, Customer may terminate the license for the Program and return the Program and any
associated materials for credit or refund.

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE PROGRAM IN LIEU OF ANY
OTHER WARRANTIES, EXPRESS OR IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED
WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX
RESPONSIBILITY TO REPLACE DEFECTIVE MEDIA OR REFUND CUSTOMER’S PAYMENT IS THE SOLE
AND EXCLUSIVE REMEDY PROVIDED TO CUSTOMER FOR BREACH OF THIS WARRANTY.

LIMITATION OF LIABILITY. IN NO EVENT SHALL TEKTRONIX, ITS RESELLERS OR OTHERS FROM
WHOM TEKTRONIX HAS OBTAINED A LICENSING RIGHT BE LIABLE FOR ANY INDIRECT, SPECIAL,
INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF OR CONNECTED WITH CUSTOMER’S
POSSESSION OR USE OF THE PROGRAM, EVEN IF TEKTRONIX OR ITS LICENSORS OR RESELLERS
HAVE ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES.

THIRD-PARTY DISCLAIMER

Except as expressly agreed otherwise, third parties from whom Tektronix may have obtained a licensing right do not warrant
the Program, do not assume any liability with respect to its use, and do not undertake to furnish any support or information
relating thereto.

GENERAL

This Agreement contains the entire agreement between the parties with respect to the use, reproduction, and transfer of the
Program.

Neither this Agreement nor the license granted herein is assignable or transferable by Customer without the prior written
consent of Tektronix.

All questions regarding this Agreement or the license granted herein should be directed to the nearest Tektronix office.
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General Safety Summary

To Avoid Fire or
Personal Injury

Symbols and Terms

Review the following safety precautions to avoid injury and prevent damage to
this product or any products connected to it. To avoid potential hazards, use this
product only as specified.

While using this product, you may need to access other parts of the system. Read
the General Safety Summary in other system manuals for warnings and cautions
related to operating the system.

NOTE. Refer also to the application online help for the General Safety Summary
specific to the application.

Connect and Disconnect Properly. Do not connect or disconnect probes or test
leads while they are connected to a voltage source.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings
and markings on the product. Consult the product manual for further ratings
information before making connections to the product.

Terms in this Manual. These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result
in injury or loss of life.

/N
VAN

CAUTION. Caution statements identify conditions or practices that could result in
damage to this product or other property.

Optional Applications on Windows-Based Oscilloscopes Installation iii
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Preface

You can use information in this manual to install any application from the
Optional Applications Software for Windows-Based Oscilloscopes CD-ROM
(CD) onto your Microsoft Windows based Tektronix oscilloscope. For compati-
bility information, refer to the table on page 2.

Documentation and Online Help

This installation manual is part of a set of documents that you can use to
understand how to operate an application. For each application, the CD contains
the software and a portable document format (PDF) file of each corresponding
document, as well as a PDF file of the online help formatted like a user manual.

The next figure shows the PDF files available on the CD for each application.

@ PDF file

PDF file
PDF file

Optional Applications CD

Reference Online Help Installation
formatted as a manual
user manual

NOTE. If you do not have an Acrobat reader to view a PDF file, you can get a
free copy of the reader from the www.adobe.com/products/acrobat web page.

The documentation set consists of the following items:

B This installation manual provides instructions on applying the authorized
Option Installation key label, installing an application from the CD, enabling
the application, and downloading an application from the Tektronix web site.

®  The application-specific reference quickly introduces you to the steps
required to take measurements and includes a diagram of the menu structure
(no reference for the TDSDDM?2 application).

Optional Applications on Windows-Based Oscilloscopes Installation v
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®  The Online Help contains the following types of information:

A Getting Started group of topics briefly describes the application, lists
oscilloscope compatibility, contains connection procedures, and includes a
deskew procedure, if required.

An Operating Basics group of topics covers basic operating principles of the
application. The sequence of topics reflects the steps you perform to operate
the application and includes definitions for all menus and options.

A Tutorial group of topics that teach you how to set up the application to
acquire a waveform, take a measurement, view the results, and save data to a
log file.

An optional Application Examples (or laboratory) group of topics includes
examples of tests and measurements to give you ideas on how to solve your
own measurement problems.

A Reference group of topics includes the parameters (range of values) for all
options and the default values.

A Measurement Algorithms group of topics with information on measure-
ment guidelines and on how the application calculates each measurement.

An optional GPIB Command Syntax group of topics contains a list of
arguments and values that you can use with the GPIB commands and their
associated parameters. To show you how to operate the application using
GPIB commands, this part may also contain a simple GPIB program.

® A printable PDF file of the online help formatted to resemble a user manual.

Optional Applications on Windows-Based Oscilloscopes Installation
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Contacting Tektronix

Phone 1-800-833-9200%

Address Tektronix
Department or name (if known)
14200 SW Karl Braun Drive

P.O. Box 500

Beaverton, OR 97077

USA
Web site www.tektronix.com
Sales support 1-800-833-9200, select option 1*
Service support 1-800-833-9200, select option 2*

Technical support Email: techsupport@tektronix.com

1-800-833-9200, select option 3*
6:00 a.m. - 5:00 p.m. Pacific time

*  This phone number is toll free in North America. After office hours, please leave a
voice mail message.
Outside North America, contact a Tektronix sales office or distributor; see the
Tektronix web site for a list of offices.
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Product Descriptions

There are different types of applications available for Tektronix Windows-based
oscilloscopes that you can use to test, to analyze, and to debug many types of
electronic devices and products. To learn about most applications, you can use
the Browse Documents button and select a document to display any PDF file
found on the Optional Applications Software on Windows-Based Oscilloscopes
CD-ROM. You can also access the Tektronix web site for information on how to
use an application to resolve complex problems, such as an application note on
how to analyze jitter.

TDSJIT2 has been replaced by TDSJIT3 Essentials and the TDSJIT2 application
is no longer included on the Optional Applications compact disc (CD). We
recommend that you upgrade to TDSJIT3 Essentials or TDSJIT3. Temporarily,
the TDSJIT3 Essentials application will operate using your TDSJIT2 option key.
Please contact your Tektronix sales office or Tektronix account manager to order
an upgrade.

To begin using TDSJIT3 Essentials, install the Jitter and Timing Analysis
Essentials application by selecting the Jitter and Timing Analysis button from
the Installation Browser on the CD. Please see the TDSJIT3 readme.txt file for
compatibility issues.

We recommended that you upgrade your oscilloscope to the latest firmware prior
to installing or operating TDSJIT3 and TDSJIT3 Essentials (see the Applications
on this CD and compatible oscilloscopes table on page 2 ). You may download
the latest firmware from the www.tektronix.com website. Follow the instructions
on page 13 for downloading firmware updates from the website to an oscillo-
scope. Be sure to select the firmware version appropriate for your specitic
oscilloscope model.

The next table lists the applications included on this optional application CD
with the compatible oscilloscope models and firmware version numbers.

Optional Applications on Windows-Based Oscilloscopes Installation 1



Product Descriptions

NOTE. To check the firmware version number of the oscilloscope, select Help>
About in the menu bar. Information will appear that includes the firmware
version.

To take a 5-time free trial of an application, check that your TDS6000,
TDS7000, or CSA7000 oscilloscope firmware version is V 2.1.0 or above. The
S-time free trial is available for all versions of firmware on TDS5000 oscillo-
scopes.

To operate a compatible application on an oscilloscope with Windows 2000, you
must install the application software version as listed in the following table and
use the following list of firmware versions or later:

TDS5000 V1.1.2 and above
TDS6000 V2.3.2 and above
TDS/CSA7000 V2.3.2 and above

If access is denied when installing software on Windows 2000, you may need
administrator rights to install.

Applications on this CD and compatible oscilloscopes

Application name

Software version

Oscilloscope model

Firmware version

RT-Eye* V1.0.0 and above | TDS6404, TDS6604, TDS7154, V 2.4.0 and above
Serial Data Compliance and Analysis TDS7254, TDS7404, CSA7154, CSA7404

InifiniBand or PCI Express (requires RT-Eye)* |V 1.0.0 and above | TDS6404, TDS6604, TDS7404, CSA7404 |V 2.4.0 and above
Serial Data Compliance and Analysis

TDSCPM2 V1.1.1 and above | TDS7154, TDS7254, TDS7404 V 2.0.0 and above
Communications Pulse Measurements CSAT7154, CSA7404 V 2.0.0 and above

TDS7054, TDS7104

V 2.1.0 and above

TDSDDM2
Disk Drive Measurements

V 1.2.3 and above

TDS7054, TDS7104

V 1.2.0 and above

TDS7404 V 1.3.0 and above
TDS7254 V 1.3.1 and above
TDS5052, TDS5054, TDS5104 V 1.0.7 and above
CSA7154, TDS7154, CSA7404 V 2.0.0 and above
TDSDVD** V 1.0.4 and above | TDS7054, TDS7104 V 2.1.0 and above
Optical Storage Analysis and Measurements TDS7154, TDS7254, TDS7404 V 2.0.0 and above
CSA7154, CSA7404 V 2.0.0 and above

TDS5052, TDS5054, TDS5104

V 1.0.7 and above

Optional Applications on Windows-Based Oscilloscopes Installation
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Applications on this CD and compatible oscilloscopes (Cont.)

Application name

Software version

Oscilloscope model

Firmware version

TDSDVI V' 1.0.0 and above | TDS7254, TDS7404, TDS6404, V' 2.2.0 and above
DVI Compliance Test Solution TDS6604, CSA7404
TDSET2 V 1.2.0 and above | TDS6404, TDS6604, TDS7054, V' 2.2.0 and above

Ethernet Compliance Test

TDS7104, TDS7154, TDS7254,
TDS7404, CSA7154, CSA7404

TDSJIT3 Jitter Analysis Measurements and
TDSJIT3E Jliter Analysis Essential Measure-
ments

V 1.1.1 and above

TDS7054, TDS7104, TDS7254, TDS7404

V 2.1.0 and above

TDS5054, TDS5104

V 1.0.9 and above

TDS6604, TDS7154, CSA7154, CSA7404

V 2.1.0 and above

TDS6404

V 2.2.0 and above

TDSPWR2
Power Analysis Measurements

V 1.3.0 and above

TDS7054, TDS7104

V 2.2.0 and above

TDS5052, TDS5054, TDS5104

V 1.1.2 and above

TDS7154, TDS7254, TDS7404,
CSA7154, CSA7404, TDS6404, TDS6604

V2.2.1 and above

TDSUSB2 for the TekScope
Universal Serial Bus Measurements Package

V 1.4.3 and above

TDS7054, TDS7104, TDS7254, TDS7404

V 1.4.1 and above

TDS5054, TDS5104

V 1.0.7 and above

TDS6604, CSA7154, TDS7154, CSA7404 |V 2.0.0 and above

TDS6404 V 2.2.0 and above
TDSUSB2 for the PC T V1.4.1 and above | TDS694C V 6.0e and above
TekConnect Adjustment Application* V1.11 and above | TekScope with TekConnect devices All

*  Requires Windows 2000 operating system.

*  Can run on a personal computer (PC) connected to a compatible oscilloscope; compatible with Windows 98 SE and

Windows 2000 operating systems.

T Can run on a PC connected to a TDS694C oscilloscope; compatible with Windows 98 SE, Windows NT 4.0, and

Windows 2000 operating systems.

*  For installation instructions, refer to page 12.

Optional Applications on Windows-Based Oscilloscopes Installation
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5-Time Free Trial

A 5-Time Free Trial is available for all applications in the previous table. You
can start and exit an application up to five times to help you evaluate Tektronix
software solutions.

NOTE. To evaluate an application, check that your TDS6000, TDS7000, or
CSA7000 oscilloscope firmware version is V 2.1.0 or above. The 5-time free trial
runs are available for all versions of firmware on TDS5000 oscilloscopes.

If an application becomes available after you receive your oscilloscope, you can
download the new application as described on page 13 to begin your free trials.

To start an application, refer to page 11.

Requirements and Restrictions

Software Versions

JRE

Read the following information before installing software.

To operate a compatible application on an oscilloscope with Windows 2000, you
must install the application software version as listed in the previous table and
use the following list of firmware versions or later:

TDS5000 V1.1.2 and above
TDS6000 V2.3.2 and above
TDS/CSA7000 V2.3.2 and above

The correct version of the Sun Java Run-time Environment (JRE) must be
installed on the oscilloscope to operate Java-based applications. If the JRE is
removed from the oscilloscope, the InstallWizard prompts you to install the JRE
when you reinstall the application software.

NOTE. The TekConnect Adjust and the Ethernet Compliance Test applications do
not use the JRE software.

Optional Applications on Windows-Based Oscilloscopes Installation
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Application Installation

This manual contains information on the following tasks:

®m  Reinstalling a newer version of an application

® [Installing an application from the optional applications compact disc (CD)

®  Applying a new label

®  Enabling an application

®  Starting an application

® [nstalling the TekConnect Adjust software from the optional applications CD

®  Downloading an application from the www.tektronix.com web site

NOTE. Some applications may require a deskew fixture or a test fixture. The
application online help includes connection procedures for these fixtures. If the
application requires a fixture, read the General Safety Summary in the fixture
user manual before you start the connection procedure.

Reinstalling an Application

Most available applications are factory installed on the hard disk in the oscillo-
scope at the time the oscilloscope is shipped. The Optional Applications
Software on Windows-Based Oscilloscopes CD-ROM serves as a way to deliver
applications to you that were introduced after you received your oscilloscope,
and as a backup in case you have to rebuild the hard disk.

The optional applications CD may contain a newer version of the application
software than the version on your oscilloscope. The www.tektronix.com web site
may include an even newer version of the application software than the version
on the CD.

Optional Applications on Windows-Based Oscilloscopes Installation 5



Application Installation

Before you continue, determine if you need to reinstall a newer version of the
application. To do this, follow these steps:

1. In the menu bar of the oscilloscope, select File > Run Application>
<application product name>.

2. In the menu bar of the application, select Help> About <application>.

The application displays information about the application that includes the
software version number.

3. Check the version number of the application on the web site. To do so,
follow these steps:

a. Access the www.tektronix.com web site and select Software & Drivers.

The Software and Firmware Finder page appears. To define the search
criteria, use one of the following methods:

B Make selections in the Browse by Product Category and Browse by
Product Series fields.

®  Enter information in the Find by Model Number or Keyword field.
b. Select Go. The search returns a list of software.

c. Scroll through the list to the desired application, select the link, and view
the web page instructions to download the application to your oscillo-
scope. The version number is at the top of the web page.

If the version number is higher than the version number in the compati-
bility table (on page 2), then follow the Downloading Updates Through
the Web Site procedures on page 13.

The next table shows an example of how to check the application version
numbers and whether or not you need to reinstall the application.

Checking the application software version number example

Application on the oscilloscope

As listed in the table on page 2

As shown on the web site

Reinstall?

V1.0.0

V1.0.0

V1.0.0

No

V1.0.0 V1.1.0 V1.1.0 Yes, from the CD
V1.0.0 V1.1.0 V1.2.0 Yes, from the web site
6 Optional Applications on Windows-Based Oscilloscopes Installation



Application Installation

Installing an Application

Windows-Based
Oscilloscopes

Normally, application software resides on the hard disk of your oscilloscope.
However, you may still need to install the application software for the following
reasons:

B You receive an application introduced after you received your oscilloscope.
®  You have to rebuild the hard disk of the oscilloscope.

B You download an update for an application from the Tektronix web site.

NOTE. For information on how to install the TekConnect Adjust application,
refer to page 12.

The table on page 2 lists the available applications, compatible oscilloscope
models, and the corresponding software version and firmware version numbers.

The installation procedure may require a keyboard attached to the oscilloscope.
You can use either a PS-2 or a USB keyboard. Though not required, it is also
convenient to attach a mouse.

Application Introduced After You Received an Oscilloscope. To install an applica-
tion that does not currently reside on the hard disk of the oscilloscope from the
optional applications CD, follow these steps:

1. If the keyboard is not installed, connect it to the oscilloscope rear panel. (The
optional-accessory keyboard plugs into the USB connector.)

2. Power on the oscilloscope to start Windows.

3. Insert the optional applications CD in the CD-ROM reader. The reader is
located on the right side panel of a TDS5000 series, and on the rear panel of
a TDS6000 series or a TDS/CSA7000 series oscilloscope.

The oscilloscope may automatically start the Installation Browser program.

4. If the oscilloscope does not start the Installation Browser program, follow
these steps:

a. Select and open the My Computer icon.

b. In the Exploring - My Computer window, select the D: (CD-ROM) drive
and then the Launch.exe file.

5. Select the Install Products button.

Optional Applications on Windows-Based Oscilloscopes Installation 7



Application Installation

6. Select the appropriate button for the application to install.

7. Follow the on-screen instructions given by the InstallShield Wizard. Answer
“OK” if prompted to install the JRE, and do not change the default directory.

The oscilloscope must reboot to complete the installation process.

Newer Version than the Application on the Oscilloscope. To install a newer version
of the application, you must first remove the version that currently resides on the
hard disk of the oscilloscope.

To remove the current version of the application software, follow these steps:
1. Select File> Minimize in the menu bar to minimize the oscilloscope.

2. Select Start> Settings> Control Panel> Add/Remove Programs.

3. Scroll through the list until the name of the application is highlighted.

4

Select the Add/Remove button and follow the on-screen instructions from
the InstallShield Wizard.

The oscilloscope must reboot to complete the removal process.

To install the newer version of software, follow the procedure on page 7.

NOTE. If you install a newer version of an application than was previously
enabled, you do not have to enter the authorized Option Installation key again.

Personal Computer (PC)  Some application software can reside on the hard disk of a PC connected to an
oscilloscope. The application controls the PC through GPIB commands sent to
and received from the oscilloscope.

First Time on the PC. To install an application that does not currently reside on the
hard disk of your PC from the optional applications CD, follow these steps:

1. Power on the PC to start Windows.

2. Insert the optional applications CD in the CD-ROM reader.

The PC may automatically start the Installation Browser program.

8 Optional Applications on Windows-Based Oscilloscopes Installation



Application Installation

3. [If the PC does not start the Installation Browser program, follow these steps:
a. Select and open the My Computer icon.

b. In the Exploring - My Computer window, select the D: (CD-ROM) drive
and then the Launch.exe file.

4. Select the Install Products button.

NOTE. The table on page 2 indicates which applications you can install on a PC.

5. Select the appropriate button for the application to install.
6. Follow the on-screen instructions given by the InstallShield Wizard.

The PC must reboot to complete the installation process.

Newer Version than the Application on the PC. To install a newer version of the
application, you must first remove the version that currently resides on the hard
disk of the PC. To remove the current version of the application software, follow
the procedure for a newer version than application on the oscilloscope on

page 8.

To install a newer version of the application, follow the previous procedure.

Configuring an Application to Operate on a PC. To run the TDSUSB2 or TDSDVD
application on a PC connected to an oscilloscope, you must follow several
configuration steps. The online help (OLH) includes a procedure to configure
your PC and oscilloscope prior to starting the application on the PC.

You can view a PDF file of the OLH to access the procedure. To do so, follow
these steps:

1. Select Start> Programs> TekApplications> <application name>> PDF. The
corresponding PDF file displays.

2. Locate and follow the procedure to configure the PC and oscilloscope.

Optional Applications on Windows-Based Oscilloscopes Installation 9



Application Installation

Applying a New Label

You may need to apply a new authorized Option Installation key label to the
rear-panel of the oscilloscope for the following reasons:

B You purchase a software license to an application already installed on the
oscilloscope; the license allows you to enable the application

B You upgrade the licensed application to a newer application
®  You purchase an application introduced after you received your oscilloscope

The label contains important information, such as the serial number of the
oscilloscope, options purchased for that serial number, and an authorized Option
Installation key number. Each label is unique.

NOTE. You do not apply a label on the TDS694C oscilloscope.

The next figures show where to apply the new label on the rear-panel of a
TDS5000 series, TDS6000 series or TDS/CSA7000 series oscilloscope.
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Enabling an Application

You must enter the authorized Option Installation key to enable all purchased
applications and product options on your oscilloscope. The key is unique; it is
specific to the serial number of the oscilloscope and purchased options.

NOTE. You do not need to enable the TekConnect Adjust application or any
applications controlled by a PC connected to a TDS694C oscilloscope.

To enter the alphanumeric key number, follow these steps:

1. If the oscilloscope powered on in the toolbar mode (default), select the Menu
button (upper right corner of the display) to put the oscilloscope into
menu-bar mode. In menu-bar mode you should see a PC-style menu across
the top of the display.

2. Go to the Utility menu in the menu bar and select Option Installation.

3. Follow the on-screen instructions to enter the alphanumeric key number
exactly as it is printed on the rear-panel label. The previous two figures show
the location of the label on the back of the oscilloscope.

Starting an Application

To start an application, select File> Run> <application name> from the menu bar
of the oscilloscope.

NOTE. You can view Online Help (OLH) topics from the oscilloscope or a PC.

To view OLH topics from an oscilloscope, follow these steps:

1. Select Start> Programs> TekApplications> <application name>> Help. The
corresponding OLH system displays.

2. Use standard techniques to navigate through the Help topics.

You can view (and print out) a PDF file of the OLH formatted to resemble a user
manual from an oscilloscope. To do so, follow these steps:

1. Select Start> Programs> TekApplications> <application name>> PDF. The
corresponding PDF file displays.

2. Use standard techniques (such as the File> Find search function) to locate
specific information.
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To start an application on a PC (TDSUSB2 or TDSDVD applications only)
select Start> Programs> TekApplications> TDSxxx> <descriptive name>.

Installing TekConnect Adjustment Software

You must install the application on the hard disk of your oscilloscope for the
application to communicate with TekConnect devices. The application software
uses internal commands to validate test hardware, and to communicate with
TekConnect devices.

NOTE. The TekConnect Adjust application does not require the JRE software and
does not need to be enabled.

1. If the keyboard is not installed, connect it to the oscilloscope rear panel (the
optional-accessory keyboard plugs into the USB connector). It may also be
convenient to connect a mouse.

2. Power on the oscilloscope to start Windows.
3. Select File> Minimize in the menu bar to minimize the oscilloscope.

4. Insert the optional applications CD in the CD-ROM reader. The reader is
located on the rear panel of a TDS6000 series or a TDS/CSA7000 series
oscilloscope.

The oscilloscope may automatically start the Installation Browser program.

S. If the oscilloscope does not start the Installation Browser program, follow
these steps:

a. Select and open the My Computer icon.

b. In the Exploring - My Computer window, select the D: (CD-ROM) drive
and then the Launch.exe file.

c. Select the TekConnect Adjust button.

6. Follow the on-screen instructions given by the InstallShield Wizard and
reboot if recommended.

For a list of other adjustment procedures required for products with TekConnect
devices, refer to the service manual for your TekConnect device. Use the
Installation Browser, and click the Browse Documents button to view the service
manuals on the CD.

After installation, the Service Manuals and the application are available on the
oscilloscope from Start Menu>Programs>Tektronix>TekConnect Adjust.
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Downloading Updates Through the Web Site

You can find information about applications for TDS5000, TDS6000, or
TDS/CSA7000 oscilloscopes on the www.tektronix.com web site. Click the
Software and Drivers link to download updates to the software and other free
applications.

NOTE. When updating an application, the Release Notes file on the www.tektro-
nix.com web site supercedes the Readme.txt file in the zipped archive.

To an Oscilloscope  To download an application when you can access the web site through the
oscilloscope, follow these steps:

1.

Access the www.tektronix.com web site and select Software & Drivers.

The Software and Firmware Finder page appears. To define the search
criteria, use one of the following methods:

®m  Select oscilloscope in the Browse by Product Category and a product in
the Browse by Product Series fields.

®  Enter information in the Find by Model Number or Keyword field.
Select Go. The search returns a list of software.

Scroll through the list to the desired application, select the link, and view the
web page instructions to download the application to your oscilloscope.

The version number is at the top of the web page.

To start the install, select the Download button. You need to register to
complete the install.

Follow the on-screen prompts.

To a PC (Installing from  To download an application when you cannot access the web site through the
Floppy Disks)  oscilloscope, follow these steps:

1.

From a PC, access the www.tektronix.com web site and select Software &
Drivers.

The Software and Firmware Finder page appears. To define the search
criteria, use one of the following methods:

®m  Select oscilloscope in the Browse by Product Category and a product in
the Browse by Product Series fields.
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14

®  Enter information in the Find by Model Number or Keyword field.
Select Go. The search returns a list of software.

Scroll through the list to the desired application, select the link for the
application with “For Floppy” in the title. View the web page instructions to
download a zip file of the application to your PC.

Select the Download button. You need to register to complete the install.
Follow the on-screen prompts.

Unzip the archive file on your PC. When you unzip the archive, the PC
creates several folders labeled Disk1, Disk2, and so on.

Copy only the contents of each folder to a floppy disk, and label the floppy
disk according to the folder name, such as Disk1, Disk2, and so on.

To install the application from floppy disks, follow these steps:

1.
2.

3
4.
5

Power on the oscilloscope to start Windows.

Select File> Minimize in the menu bar to minimize the oscilloscope.
Insert Disk1 in the floppy disk drive.

Select and open the My Computer icon.

In the Exploring - My Computer window, select the A: (3 1/2 Floppy) drive.

NOTE. Additional information about the application is located in a
Readme.txt file in the zipped archive. Read the file before you continue.

When updating an application, the Release Notes file on the www.tektro-
nix.com web site supercedes the Readme.txt file in the zipped archive.

Select the Setup.exe file to start the install program.
Follow the on-screen instructions given by the InstallShield Wizard.

Wait until after the floppy disk drive LED has gone out to remove each
floppy disk and insert another.

When the installation is complete, the oscilloscope will restart. Remove the
final floppy disk and reboot the oscilloscope.
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